CHAS mit Serial/USB-Adapter zum laufen bringen (PCU auslesen)


sepp

Neues Mitglied
24.11.2018
15
Hallo ich versuche die PCU meines Think City mit Hilfe des Programms CHAS auszulesen.

Ich verwenden den UC232A- Usb/Serial Adapter von ATEN auf einem Windows7 Rechner und bekomme keine Verbindung.

Allerdings glaube ich das das Programm CHAS V2.6 nicht richtig funktioniert da ich schon bei der Erstellung der chas.cfg Datei (welche Port und Baudrate enthält) die Fehlermeldungen " Windows returned error while writing to C:\CHAS\Chas.cfg file" und "Windows returned error while loading Variable Data file. Code 2".

Chas speichert mir keine einzige Datei, und benötigten Dateien manuell in den Ordner kopieren funktioniert auch nicht.

Die Verbindung zum Siadis-Stecker habe ich mir selbst gemacht mit folgendem Pinout, welches jedoch funktionieren sollte denn bei anderer PInbelegung bekomme ich bei der Verbindung eine Fehlermeldung "wrong connection" oder so ähnlich.
SIADIS PCU RS232
1 6/62 2 TX
2 5/62 3 RX
3 4/62 7 DWNLD
4 3/62 5 GND

Hat da Jemand Erfahung oder eine Ahnung woran es liegen könnte? Hab das Programm schon mehrmals neu installiert (ohne Fehler) und leider keinen PC mit Serieller Schnittstelle zur Hand.

Wäre Super wenn mir da wer helfen könnte, (im norwegischen Ebil-Forum werde ich mein glück auch noch versuchen).
Vielen Dank lg Sepp
 

thegray

Bekanntes Mitglied
15.04.2008
8.215
Hi - hm
Hallo ich versuche die PCU meines Think City mit Hilfe des Programms CHAS auszulesen.

Ich verwenden den UC232A- Usb/Serial Adapter von ATEN auf einem Windows7 Rechner und bekomme keine Verbindung.

....................

......welches jedoch funktionieren sollte denn bei anderer PInbelegung bekomme ich bei der Verbindung eine Fehlermeldung "wrong connection" oder so ähnlich.
...............

Wäre Super wenn mir da wer helfen könnte, (im norwegischen Ebil-Forum werde ich mein glück auch noch versuchen).
Vielen Dank lg Sepp
Hi - also bei der APP. bin ich außen vor.
Aber mal Nachgefragt und allgemeines - wenn nicht jetzt vielleicht hilft es ein anders mal.

Also wenn ich das Lese - und dann "habe keinen Rechner mit RS232"......

Also Frage - Nach dem Letzten Satz könnte man es so interpretieren das es eine Kommunikation zumindest Rudimentär gäbe.

Das was davor steht - könnte man so interpretieren das man sich nicht sicher ist das....

Also der USB Adapter ist ja ein ganz Fixer der will auf bis 900.000 bit schaffen - auf welcher Seite ?
Und die Tatsache das Hinweis des Hardwareherstellers (ja ja Leute ich lese genau und ich merke mir auch alles HIER ist es 7) auf Win8 und neuer und das es einen SoftwareDeveloperKit gibt - weist daruf hin das es zu Problemen kommen kann.
Wenn der besonders schnell auf der RS232 Seite sein will dann kann es gerne im Firmcode Zeitkritsche Sachen geben oder das Timing der io-Signale, GRADE erst recht wenn der Rechner auch die Serielen Telegramme des Fahrzeugs interpretieren muß.

Wenn das der Fall ist - Im Zweifel (falls kein klassischer PC zu bekommen)dann doch einen absolut originalen FTDI-Chip im usb Umsetzter verwenden - kann schon mal die Nerfen schonen. (anmerkung die FTDI-HW ist schon lange auf den Markt und war auch sehr gut mit Bibliotheken und Erfahrungen versorgt - so das die eine Zeit lang QUASI-Standard waren für RS232 zu USB und es zuverlässig sein sollte.


BTW- Schön sieht man das (ja ja - die kritiker wieder hinkt weil umgekerhrte Vorzeichen ) wer die CANION mit billigen CANBUS Adapteren verwendet (mit Hintergrund sich dann auf Fehlersuche ) - hier ist zwar zumindest die CANBUS Siganalverwaltung in einem Interpreterchip im OBD-Adapter und die Software/APP muß da weniger leisten - NUR sind in den Billigen die µController mit dem Timing im CANBUS sodamit ausgelastet - das sie wie ich sehen konnte ein Großteil der Nachrichten zum und aus "Drillings"-BUS nicht gepuffert werden konnten und/oder das Timing der Signale; die Verbindung APP-CANBUS in Sekunden wieder zusammenbricht.

"timming ist manchmal alles"
 

R.M

Bekanntes Mitglied
24.12.2006
9.783
Ohne CAN Bus Adapter wird es wohl kaum gehen ich benutze den von PEAK der funktioniert bis jetzt bei den meisten Fahrzeugen z.B. Vectrix, Zivan Lader und diverse Motorcontroller.

Gruß

Roman
 

sepp

Neues Mitglied
24.11.2018
15
ja danke vl. besorge ich mir noch einen Adapter mit FTDI Chip, diesen hatte ich schon.

CanBus Adapter habe ich auch den von Peak nur keine Software um die PCU auszulesen kann mir die eventuell Jemand zukommen lassen? bzw. welche Software wäre dass?

Danke schon mal
 

Teasie

Neues Mitglied
09.08.2019
35
Hallo, kann mir jemand sagen, wo ich diese CHAS Software herbekomme?

Gruß aus der Wesermarsch
 

Teasie

Neues Mitglied
09.08.2019
35
Hallo, danke für das Angebot, habe das Programm bereits installiert, komme aber nicht klar, denn ich bekomme keine Verbindung zur PCU ?
 

Werni

Aktives Mitglied
19.02.2019
481
Der Fehler

" Windows returned error while writing to C:\CHAS\Chas.cfg file"

hat erstmal nix mit der Hardware zu tun.

Da müssen die Schreibrechte auf diese Datei gegeben werden, das ist wohl nicht der Fall. ODER die Datei chas.cfg befindet sich gar nicht im Verzeichnis c:\chas

Bevor das nicht geregelt ist wird wahrscheinlich jeder Zugriffsversuch auf die Hardware ins Leere gehen.

Gruß,

Werner
 

Teasie

Neues Mitglied
09.08.2019
35
Hallo Werner, in der Anleitung steht dass mit dem setup des com ports und der Baudrate, das Programm eine chas.cfg datei erstellt, aber genau das ist nicht der Fall, trotz aller gegebenen Rechte und ausführung als Admin :unsure:

Matthias
 

Teasie

Neues Mitglied
09.08.2019
35
Ich hätte noch eine Frage zu dem Chas Programm, muß ich eine Verbindung zu dem Stecker im Beifahrerfussraum herstellen oder sollte es auch am Obd Anschluss funktionieren?

Matthias z.Zt ratlos in der Wesermarsch
 

Teasie

Neues Mitglied
09.08.2019
35
Hallo prensel, nun habe ich alles zusammen, Fußraumstecker nach Elbiwiki mit RS232-USB Adapter verbunden und CHAS bekommt trotzdem keine verbindung :-( alle Baudraten ausprobiert - nichts.
völlig ratlos in der Wesermarsch
Matthias
 

Jens-Uwe Runge

Neues Mitglied
22.06.2007
29
Lübeck
Hallo Teasie,

1) welche Stecker- bzw. PCU-Version hast du denn eingebaut ? Mir scheint, dass im elbilwiki bei Gen2 ein Fehler vorliegt. Nach meinen Unterlagen (getestete Konfiguration) müsste man bei dem flachen Stecker (Gen2) folgende Belegung haben:
(PCU - Kabelfarbe - Flachstecker Pin - Sub-D-Stecker Pin - RS232 an PC)
TxD - grün - 1 - 2 - RxD
RxD - grün/weiß - 2 - 3 - TxD
EnDL - weiß - 3 - 7 - RTS
GND - schwarz/grün - 4 - 5 - GND

2) hast du auch versucht, eine Diagnosedatendatei (*.var, Auswahl über F4) zu laden?
Wenn die Verbindung grundsätzlich funktioniert, sollte man oben rechts im Fenster immerhin die PCU-SW Version angezeigt bekommen.

Grüße von der Ostsee,
Jens-Uwe
 

Teasie

Neues Mitglied
09.08.2019
35
Hallo Jens-Uwe, danke, das hat weitergeholfen, ich habe Gen1 und andere Farben, aber CHAS steht auf communication, in dem Feld ECU SW version stehen einige kryptische Zeichen und das Programm fragt nach einem Key?
Zündschlüssel steckt und Fahrzeug ist auf Bereitschaft.
Grüße aus der Wesermarsch
Matthias
 

Anhänge

Zuletzt bearbeitet:

Jens-Uwe Runge

Neues Mitglied
22.06.2007
29
Lübeck
Sieht so aus, als ob die Baudrate nicht passend eingestellt ist (muß unter Setup bei jedem Programmstart 1x gesetzt werden, das auslesen aus chas.cfg funktioniert laut Anleitung nicht). Die PCU-Version sollte im Klartext lesbar sein.

Jens-Uwe
 

Teasie

Neues Mitglied
09.08.2019
35
Hallo,
hoffe angenehme Feiertage gehabt zu haben.
Ich habe nochmal alles gelesene versucht und bekomme keinen Kontakt zu meiner PCU :-(.
Ich wüsste nicht, wo der Fehler liegt.
Meine Frage wäre, hat jemand die Muße und das know how eine Step by step Anleitung zu erstellen ( wo müssten Systemeinstellungen geändert werden, welche Bautrate wo einstellen...?).
Ich würde mich ungern von einem heilen Zebraakku trennen nur weil meiner Vermutung nach in der PCU meines Think eine Fehlermeldung vorliegt, die gelöscht werden sollte, denn Hardwaremäßig wurde ein Fehler in der PCU beseitigt.
Muß nicht so sein, aber ohne Klarheit ist auch Sch...

Grüße aus der Wesermarsch
 

sepp

Neues Mitglied
24.11.2018
15
Hallo Teasie,

also wenn du deine Informationen über deine Zebrabatterie haben willst wiso verwendest du nicht den Zebramonitor und siehst dir die Details deiner Batterie an? Da solltest du meiner Meinung nach alle Fehlermeldungen welche die Batterie Betreffen sehen und Löschen können.
LG Sepp
 

Teasie

Neues Mitglied
09.08.2019
35
Hallo Sepp, danke für die Info Zebramonitor läuft 1a, daher weiß ich, das die Batterie in "best Condition" ist, was fehlt ist die Ladefreigabe aus der PCU!
Guten Rutsch allerseits
Teasie
 

sepp

Neues Mitglied
24.11.2018
15
also ich hatte einmal den Runden Datenstecker an der PCU nicht sauber angschlossen und danach folgende Fehlermeldung erhalten. Aber nachdem der Stecker wieder richtig angesteckt war lies sich der Fehler im Zebramonitor löschen und alles war wieder gut.

mehr weiß ich dazu leider nicht.
 

Anhänge


Anmelden

Neue Themen

Adblock 😩

Wir verstehen, dass Werbung nervig sein kann!

Der Adblock macht einen großartigen Job bei der Blockierung von Anzeigen, aber er blockiert auch nützliche Funktionen unserer Website. Für die beste Website-Erfahrung deaktiviere bitte deinen AdBlocker.

Diese Meldung wird nicht angezeigt wenn du angemeldet bist.
Du kannst dich hier registrieren

Ich habe meinen Adblock deaktiviert!
Ignorieren